Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамСоздание и изменение объект…

1С:Предприятие 8.2 /
Разработчикам /
Создание и изменение объектов метаданных

Оглавление

Обработчик события ОбработкаЗаполнения

См. также

 

В случае если в силу каких-либо условий необходимо ограничивать ввод на основании по команде " Создать на основании ", то такую проверку следует выполнять в обработчике ОбработкаЗаполнения. Например, это могут быть проверки вида:

Для оповещения пользователя о причинах отказа, в обработчике ОбработкаЗаполнения следует использовать исключения:

Процедура ОбработкаЗаполнения(ДанныеЗаполнения, СтандартнаяОбработка) 
	Если ТипЗнч(ДанныеЗаполнения) = Тип("СправочникСсылка.Сотрудники") Тогда 
		Если ПолучитьЗначениеРеквизита(ДанныеЗаполнения, "ЭтоГруппа") = Истина Тогда 
			ВызватьИсключение "Ввод приказа о приеме на основании группы сотрудников невозможен!
			|Выберите сотрудника. Для раскрытия группы используйте клавиши Ctrl и стрелку вниз"; 
		Иначе 
			// обработка заполнения объекта по данным заполнения 
		КонецЕсли; 
	КонецЕсли; 
КонецПроцедуры

При этом не рекомендуются какие-либо иные решения для подобных проверок. В частности, не следует создавать дополнительные команды для ввода на основании и размещать проверки в обработчиках этих команд.

См. также


Нас находят: 1с8 процедура обработка заполнения, обработка заполнения 1с, обработказаполнения 8 2, обработчик события ОбработкаЗаполнения, обработказаполнения 1с, событие ОбработкаЗаполнения, 1с обработказаполнения, 1с обработказаполнения когда вызывается, ОбработкаЗаполнения с выбором из списка 1с 8 2, обработказаполнения данныезаполнения


Подписка на новости RSS     Добавьте в закладки Google fusion     Мы в Google+    

 

Мы ВКонтакте

 

Мы на Facebook