Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамСоглашения при написании ко…

1С:Предприятие 8.2 /
Разработчикам /
Соглашения при написании кода

Оглавление

Общие требования к построению конструкций встроенного языка

См. также

 

1. В конструкциях встроенного языка ключевые слова пишутся канонически (как в документации или Синтакс-помощнике ).
Правильно:

КонецЕсли

Неправильно:

конецЕсли, КОНЕЦЕСЛИ, конецесли, Конецесли .

2. При следовании друг за другом нескольких операторов присваивания, допускается выравнивать их следующим образом:

ДиалогВыбора.ПолноеИмяФайла = ИмяФайла; 
ДиалогВыбора.Каталог = ИмяПути; 
ДиалогВыбора.Заголовок = НСтр("ru = 'Выберите файл со списком запросов'"); 
ДиалогВыбора.Фильтр = НСтр("ru = 'Файлы запросов (*.sel)|*.sel|Все файлы (*.*)|*.*'"); 
ДиалогВыбора.Расширение = "sel";

При этом не следует выравнивать операторы одинаково по всему модулю - рекомендуется делать выравнивание только для операторов, расположенных рядом.

3. Составные логические выражения в ЕслиКонецЕсли переносятся согласно правилам переноса выражений.

4. Результат функции, возвращающей логическое значение , не следует проверять путем сравнения с логической константой.
Правильно:

Если ЭтоНовый() Тогда

Неправильно:

Если ЭтоНовый() = Истина Тогда

5. В тех случаях, когда требуется сравнивать результаты каких-либо выражений, следует предварительно присваивать результаты этих выражений промежуточным переменным, и сравнивать уже сами эти переменные.
Правильно:

Ответ = Вопрос(НСтр("ru = 'Данные еще не записаны. Записать?'"), РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Да); 
Если Ответ = КодВозвратаДиалога.Да Тогда 
	Записать(); 
Иначе 
	Возврат; 
КонецЕсли;

Неправильно:

Если Вопрос(НСтр("ru = 'Данные еще не записаны. Записать?'"), РежимДиалогаВопрос.ДаНет,, КодВозвратаДиалога.Да) = КодВозвратаДиалога.Да Тогда 
	Записать(); 
Иначе 
	Возврат;
КонецЕсли;

6. Необходимо использовать системные наборы значений везде, где возможно их применить, например , вместо Символ(10) следует использовать Символы.ПС.

См. также


Нас находят: 1с Неправильная константа типа Дата Ответ = Вопрос(НСтр, выровнять код 1С 8 2, где применять конструкцию ЭтоНовый 1С 8 2


Подписка на новости RSS     Добавьте в закладки Google fusion     Мы в Google+    

 

Мы ВКонтакте

 

Мы на Facebook