Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамРазработка пользовательских…

1С:Предприятие 8.2 /
Разработчикам /
Разработка пользовательских интерфейсов

Оглавление

Особенности реализации команд для форм списков

См. также

 

Методическая рекомендация (полезный совет)

При разработке команд непосредственно в формах динамических списков, логика команды должна учитывать возможность того, что пользователь может сгруппировать динамический список по одной из колонок. Если логика команды не предусматривает обработку выделенных строк группировки, то их необходимо пропускать. При этом рекомендуется выдавать сообщение, если в списке выделена только одна строка группировки:

&НаКлиенте
Процедура КомандаВФорме(Команда)
	МассивОбъектов = Элементы.Список.ВыделенныеСтроки;
	Если МассивОбъектов.Количество() = 1 
		И ТипЗнч(МассивОбъектов [0]) <> <ОжидаемыйТип> Тогда
		Предупреждение(НСтр("ru = 'Команда не может быть выполнена для указанного объекта.'"));
		Возврат;
	КонецЕсли;
	Для Каждого ОбъектИзСписка Из МассивОбъектов Цикл
		Если ТипЗнч(ОбъектИзСписка) <> <ОжидаемыйТип> Тогда
			Продолжить;
		КонецЕсли;
		
		// Обработка объекта строки.
		// ...
	КонецЦикла; 
 КонецПроцедуры 

См. также


Нас находят: команда не может быть выполнена для указанного объекта 1с, команда не может быть выполнена для указанного объекта 1с 8 3, команда не может быть выполнена для указанного объекта, !команда -у тячпзж, командна не может быть выполнена для указанного объекта при выборе печатной формы, общаякоманда показатьдвижениядокумента 1с 8 3 команда не может быть выполнена для указанного объекта, Объект Реализации Сумма Включает НДС в 1c 8 3 как реализовать в коде, ПоказатьДвиженияДокумента не может быть выполнена для указанного объекта, справочник прочиерасходы в ут11 команда не может быть выполнена для указанного объекта, 1с83 команда не может быть выполнена для днного объекта


Подписка на новости RSS     Добавьте в закладки Google fusion     Мы в Google+    

 

Мы ВКонтакте

 

Мы на Facebook