Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамУниверсальные механизмы

1С:Предприятие 8.2 /
Разработчикам /
Универсальные механизмы

Оглавление

Подтверждение завершения работы с программой

Краткое описание механизма

Описание принципов действия

 

Краткое описание механизма

Механизм подтверждения завершения работы с программой предназначен для исключения случаев случайного закрытия программы пользователем.
После задействования данного механизма при закрытии программы пользователю выводится запрос на подтверждение закрытия.

Описание принципов действия

Вывод запроса на подтверждение закрытия программы настраивается для каждого пользователя индивидуально. Данная возможность реализуется с помощью стандартного механизма настроек пользователя. В плане видов характеристикНастройкиПользователей механизму подтверждения завершения работы с программой соответствует предопределенный элемент – ЗапрашиватьПодтверждениеПриЗакрытии, с типом значения Булево.

Вывод запроса на подтверждение выполняется в обработчике событияПередЗавершениемРаботыСистемы() модуля приложения:

Процедура ПередЗавершениемРаботыСистемы(Отказ) 
	Если глЗапрашиватьПодтверждениеПриЗакрытии <> Ложь Тогда
		ЗапрашиватьПотверждение = ПолучитьЗначениеПоУмолчанию(глТекущийПользователь, "ЗапрашиватьПодтверждениеПриЗакрытии");
		Если ЗапрашиватьПотверждение Тогда
			Ответ = Вопрос("Завершить работу с программой?", РежимДиалогаВопрос.ДаНет);
			Отказ = (Ответ = КодВозвратаДиалога.Нет);
		КонецЕсли;
	КонецЕсли;
 КонецПроцедуры 

Экспортная переменная модуля приложения глЗапрашиватьПодтверждениеПриЗакрытии предназначения для "внутреннего" отключения вывода запроса на подтверждения, не связанного с настройками пользователя. Это может быть необходимо в случаях, когда закрытие программы инициируется некоторыми механизмами конфигурации и вывод запроса при этом не нужен. Например, в механизме принудительного завершения работы с пользователями.
Для того, чтобы избежать появления данного запроса значение данной переменной необходимо установить в ЛОЖЬ:

глЗапрашиватьПодтверждениеПриЗакрытии = Ложь; 
ЗавершитьРаботуСистемы();

Нас находят: ЗапрашиватьПодтверждениеПриЗакрытии, при завершении работы программа 1С не спрашивает подтверждение


Подписка на новости RSS     Добавьте в закладки Google fusion     Мы в Google+    

 

Мы ВКонтакте

 

Мы на Facebook