Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамСоглашения при написании ко…

1С:Предприятие 8.2 /
Разработчикам /
Соглашения при написании кода

Оглавление

Тексты модулей

См. также

 

1. Тексты модулей должны быть написаны на русском языке. В текстах модулях не допускается использовать букву "ё".

Методическая рекомендация (полезный совет)

2. Программные модули не должны иметь неиспользуемых процедур и функций.

3. Программные модули не должны иметь закомментированных фрагментов кода, а также фрагментов, которые каким-либо образом связаны с процессом разработки (отладочный код, служебные отметки) и с конкретными разработчиками этого кода. Например, недопустимо оставлять подобные фрагменты в коде после завершения отладки или рефакторинга:

Процедура ПередУдалением(Отказ)
	// Если Истина Тогда
	// Сообщение("Для отладки");
	// КонецЕсли;
 КонецПроцедуры 

также неправильно:

Процедура ПередУдалением(Отказ)
	Если Истина Тогда
		// Иванов: доделать 
	КонецЕсли;
КонецПроцедуры

Правильно: после завершения отладки или рефакторинга удалить обработчик ПередУдалением из кода.

4. Тексты модулей оформляются по принципу "один оператор в одной строке". Наличие нескольких операторов допускается только для "однотипных" операторов присваивания, например:

НачальныйИндекс = 0; Индекс = 0; Результат = 0;

5. Текст модуля должен быть оформлен синтаксическим отступом. Для синтаксического отступа используется табуляция (а не пробелы, чтобы при смене числа знаков в табуляции выравнивание текста сохранялось).

Размер табуляции - стандартный (4 символа).

5.1. С крайней левой позиции должны начинаться только:

5.2. Процедуры НачатьТранзакцию и ЗафиксироватьТранзакцию не являются операторными скобками, поэтому текст внутри этих процедур не сдвигается.

6. При длине строки более 120 символов следует использовать переносы. Строки длиннее 120 символов делать не рекомендуется, за исключением тех случаев, когда перенос невозможен (например, в коде определена длинная строковая константа, которая выводится без переносов в окно сообщений с помощью объекта СообщениеПользователю).

См. также: Перенос выражений.

7.1. Тексты модулей могут содержать комментарии. Комментарии должны быть достаточно понятными, чтобы пояснять работу модуля или комментируемого оператора. Тексты комментариев должны составляться по правилам русского языка, в деловом стиле, быть эмоционально сдержанными и не содержать слов, не относящихся к функциональности программы.

7.2. Небольшие комментарии пишутся в конце строки, которую комментируют, например:

НайденныеОшибки.Колонки.Добавить("Номер"); // для совместимости

Большие комментарии или комментарии к фрагменту кода пишутся перед комментируемым кодом в отдельной строке.

7.3. Большие комментарии должны начинаться с большой буквы и заканчиваться точкой. Текст выравнивается по левой границе комментируемого фрагмента. Между символами комментария "//" и текстом комментария должен быть пробел.

// Инициализируем переменные для выполнения расчетов,
// которые выполняются далее по тексту модуля.
ТекущаяДата = ОбщегоНазначения.ПолучитьРабочуюДату(); 
ТекущийГод = Год(ТекущаяДата); 
ТекущийМесяц = Месяц(ТекущаяДата); 
ТекущаяНеделя = НеделяГода(ТекущаяДата); 
ТекущийДень = День(ТекущаяДата);

См. также


Подписка на новости RSS     Добавьте в закладки Google fusion     Мы в Google+    

 

Мы ВКонтакте

 

Мы на Facebook