Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамРазработка пользовательских…

1С:Предприятие 8.2 /
Разработчикам /
Разработка пользовательских интерфейсов

Оглавление

Использование объекта ДанныеФормыКоллекция

См. также

 

1. В целях оптимизации объема данных, передаваемых между клиентом и сервером, платформа 1С:Предприятие по-особому организует передачу объектов формы типа ДанныеФормыКоллекция. Данные таких объектов передаются определенными порциями таким образом, что новые порции данных передаются с сервера на клиент только по мере обращения к этим данным на клиенте. Необходимо учитывать эту особенность при разработке форм, т.к. в противном случае, код формы может приводить к излишним неявным серверным вызовам, инициируемым платформой.

2. При работе с объектами типа ДанныеФормыКоллекция, если предполагается, что объект типа ДанныеФормыКоллекция может содержать большое количество строк (нужно ориентироваться на количество от 20 строк), необходимо придерживаться следующих рекомендаций :

Например, если решается задача по проверке в объекте строк, удовлетворяющих некоторому условию, то
неправильно:

&НаКлиенте
Процедура ПроверитьНаличиеСтрокСНезаполненнымКоличеством()
	Если Объект.Товары.НайтиСтроки(Новый Структура("Количество", 0 )).Количество() > 0 Тогда
		Предупреждение(НСтр("ru = 'Есть строки с нулевым количеством'"));
	КонецЕсли;
 КонецПроцедуры 

правильно выполнять один явный вызов сервера :

&НаСервере
Функция ЕстьСтрокиСНулевымКоличеством()
	Возврат Объект.Товары.НайтиСтроки(Новый Структура("Количество", 0 )).Количество() > 0; 
 КонецФункции 

&НаКлиенте
Процедура ПроверитьНаличиеСтрокСНезаполненнымКоличеством()
	Если ЕстьСтрокиСНулевымКоличеством() Тогда
		Предупреждение(НСтр("ru = 'Есть строки с нулевым количеством'"));
	КонецЕсли;
КонецПроцедуры

См. также


Нас находят: ДанныеФормыКоллекция, 1с ДанныеФормыКоллекция, ДанныеФормыКоллекция 1с, 1С 8 3 ДанныеформыКоллекция, данныеформыколлекция найти, данныеформыколлекция в таблицу значений, ДанныеФормыКоллекция в 1с, данные формы коллекции 1с, 1с 8 3 товары найтистроки, https://yandex ru/clck/jsredir?from=yandex ru%3Bsearch%3Bweb%3B%3B&text=&etext=1839 cAoq2bxnUSjw2HrwCliJFTj9bYNUFaxe0eI402qdIqpITKrKXC9OjmLybaaqWaga 6fb167d1ade38e3a80e70431a866630a003c3832&uuid=&state=_BLhILn4SxNIvvL0W45KSic66uCIg23qh8iRG9


Подписка на новости RSS         Мы в Google+    

 

Мы на Facebook