Меню


Курсы СтимулСправочникПолезные материалы1С:Предприятие 8.2РазработчикамСоздание и изменение объект…

1С:Предприятие 8.2 /
Разработчикам /
Создание и изменение объектов метаданных

Оглавление

Обработчик события ПередЗаписью

1. В данном обработчике, как правило, должны выполняться действия, связанные с заполнением значений реквизитов объекта (набора записей, значения константы; далее упрощенно - "объект"), проверки правильности их заполнения, связанности состояния объекта с некоторыми внешними данными. Также в данном обработчике следует выполнять действия, связанные с обращением к "старым" значениям реквизитов объекта, сохраненным в базу данных (имеет смысл при редактировании уже записанных ранее объектов, наборов записей и т.п.).

См. также раздел «Проверки, выполняемые в и вне транзакции записи объекта» статьи «Обработчик события ОбработкаПроверкиЗаполнения»

2. Содержимое процедуры- обработчика событияПередЗаписью условно должно разделяться на две части:

Процедура ПередЗаписью(Отказ) 
	// действия, которые должны выполняться всегда, в том числе и при обмене данных 
	// ...
	Если ОбменДанными.Загрузка Тогда 
		Возврат; 
	КонецЕсли; 
	
	// действия, выполняемые в случае, если запись инициирована не механизмом обмена данными 
	// ...
 КонецПроцедуры 

В большинстве случаев, все действия выполняемые в обработчике ПередЗаписью должны располагаться в модуле после конструкции

Если ОбменДанными.Загрузка Тогда 
	Возврат; 
КонецЕсли;

То есть они не должны выполняться при записи объекта через механизм обмена данными, поскольку они уже были выполнены для объекта в том узле, где он был создан. В случае исключений, причина исключения из этого правила должна быть описана в комментарии к выполняемым действиям.


Нас находят: клиентский обработчик события процедура передзаписью радченко, ри подписке бит_аб_передзаписьюназначения на событие передзаписью произошла ошибка обработчик события не найден, процедура передзаписью, При подписке на событие передЗаписью Обработчик события не найден, 1с автономнаяработапроверитьвозможностьзаписиобщихданных, 1сзуп Ошибка в базе-корреспонденте: При подписке ЗаполнитьКраткийСоставДокументовБазовая на событие ПередЗаписью произошла ошибка, При подписке ЕГАИСПередЗаписьюДокументаИБ, При подписке ЗаполнитьФизическиеЛицаТабличныхЧастейДокументовБазовая на событие ПередЗаписью произошла ошибка Метод обработчика события ЗаполнитьФизическиеЛицаТабличныхЧастейДокументов не найден, Процедура ПередЗаписью набор записей, При подписке АвтономнаяРаботаПроверитьВозможностьЗаписиОбщихДанных на событие ПередЗаписью произошла ошибка Обработчик события не найден


Подписка на новости RSS

Мы на Facebook